Technical issues with editing documents and forms.
Incident Report for airSlate
Resolved
The issue has been resolved. All services are operating normally now.
Posted May 02, 2022 - 16:13 UTC
Update
The issue is relevant for Google Chrome browser. Please use alternative browsers for now.
Posted May 02, 2022 - 16:10 UTC
Investigating
There may be issues with editing documents and forms. Our Engineers are already investigating the issue. We are sorry for any inconvenience.
Posted May 02, 2022 - 16:06 UTC
This incident affected: Web.