"Limits reached" error and general platform slowdown

Incident Report for airSlate

Resolved

The incident has been resolved. All services operate normally now. Thank you for your continuous patience.
Posted Oct 28, 2025 - 15:29 UTC

Identified

The issue continues with the 500th error reproducing on the workflow creation step. Our team continues to diligently work on solution delivery.
Posted Oct 28, 2025 - 14:35 UTC

Monitoring

The root cause of the issue has been identified, and a fix has been rolled out. We are monitoring the situation.
Posted Oct 28, 2025 - 14:04 UTC

Investigating

We are currently experiencing a general platform slowdown and a "limits reached" error. Our team is working to resolve this problem as soon as possible.
Posted Oct 28, 2025 - 13:05 UTC
This incident affected: Web.