Outlook integration is not working correctly.

Incident Report for airSlate

Resolved

The incident has been resolved. All systems are operating as expected. Thank you for your patience.
Posted Jun 18, 2025 - 20:56 UTC

Update

Whole Outlook integration is unavailable. New connections cannot be set up. Team continues to work on the fix.
Posted Jun 18, 2025 - 18:12 UTC

Investigating

We are currently having issues with MS Outlook integrations. The respective bots are failing with a 422 error. Our team is already working on the issue. We appreciate your patience.
Posted Jun 18, 2025 - 16:32 UTC
This incident affected: Web.