Documents are stuck and are not progressing further

Incident Report for airSlate

Resolved

The issue has been successfully resolved. All services are operating normally. We appreciate your patience.
Posted May 28, 2025 - 17:21 UTC

Investigating

We are currently having issues with documents being stuck right after sending. Our team is already diligently working on issue detection and resolution.
Posted May 28, 2025 - 16:27 UTC
This incident affected: Web.